October 17, 2017
Archives  News  Early Galactic Battlegrounds System Reqs  


Thursday, February 21, 2002
 

Click to enlarge
Early Galactic Battlegrounds System Reqs
8:45 AM | Andy Largent | Comment on this story

Aspyr yesterday launched their mini-site for the upcoming real-time strategy game based on the Star Wars universe, Galactic Battlegrounds. This acclaimed game was created by LucasArts using the Age of Empires engine, so many RTS fans will already be familiar with the basics of the game. Players will be able to control the forces of the Dark Side or the Rebel Alliance.

The mini-site lists some preliminary system requirements for the game. They seem relatively tame at this point, though do keep in mind they could change before the game is released:

  • Mac OS 8.6, Mac OS X 10.1
  • CarbonLib 1.4 or higher
  • 64 MB built-in memory
  • Stock G3 or G4 of 333 MHz or greater
  • 4x CD-ROM compatible drive

For more information on the game or to check out some screen shots, head over to the Aspyr site. Westlake Interactive is currently working on the port and expects to complete its work around April. Pending final testing and approval, it should be released soon after.

Star Wars Galactic Battlegrounds
Westlake Interactive
Buy Star Wars Galactic Battlegrounds


Other Mac Games News for Thursday, February 21, 2002

IMG Store Offers Sims Super Bundle, Harry Potter1:05 PM
Harry Potter Officially Ships12:41 PM
Update on Links Championship Edition10:46 AM
Simon the Sorcerer II Carbonized9:41 AM
Pangea Needs Your Help with CompUSA9:13 AM
Early Galactic Battlegrounds System Reqs8:45 AM
MacMAME 0.58 Released6:00 AM
Neverwinter Nights Status Update6:00 AM
Price Changes, New Updates for WarBirds III6:00 AM
Warcraft III Undead in Depth6:00 AM
 
View all of the Mac games news for Thursday, February 21, 2002 on one page

Mac Games News for Wednesday, February 20, 2002

IMG Reviews the FunStick Pro F-10812:12 PM
B&W Support FAQ Posted; Bundle Deal Continues11:42 AM
BlizzMac Site Opens10:26 AM
Baldur's Gate II Updated to Version 1.16:00 AM
Otto Matic Adds FSAA and Truform Support6:00 AM
QuakeCon 2002 Announced6:00 AM
Warcraft III Changes6:00 AM
 
View all of the Mac games news for Wednesday, February 20, 2002 on one page


Recent Mac Games News

Tuesday, February 19, 2002
Monday, February 18, 2002
Friday, February 15, 2002
Thursday, February 14, 2002
Wednesday, February 13, 2002


Search for other Mac games news stories or browse our Mac Games News Archive.



Archives  News  Early Galactic Battlegrounds System Reqs