November 18, 2017
Archives  News  Eschalon Book II: Mac Requirements  


Monday, August 11, 2008
 

Click to enlarge
Eschalon Book II: Mac Requirements
6:00 AM | Cord Kruse | 2 comments

Basilisk Games has released the seventh in its weekly Q&A series featuring answers to fan questions about the upcoming Eschalon: Book II, the second in the company's "old school" RPG series. This latest answer addresses whether or not the low end requirements for Mac users will change for the next installment in the series.

Question #7: [Jude]Will the Mac version still work on a Power Mac G4 running OS X 10.3.9?

As of right now, yes it will. We are at the mercy of the company who develops the compiler, meaning if they change their baseline requirements for the Mac then so must we, but right now a G4 running 10.3.9 is still the current low-end Mac requirement.
Read the entire Q&A list at the link provided below.

Basilisk Forum: Eschalon Book II Question Of The Week
Basilisk Games
Eschalon: Book II
Buy Eschalon: Book II


Other Mac Games News for Monday, August 11, 2008

MacRaider, Kerrie Reay Passes Away9:03 AM
BlizzCon 2008 Website Opens6:00 AM
Diablo III: Beta Keys, Achievements, Cow Level Failure6:00 AM
• Eschalon Book II: Mac Requirements6:00 AM
Reel Deal Casino: Gold Rush Now Available6:00 AM
Vendetta Online Updated6:00 AM
 
View all of the Mac games news for Monday, August 11, 2008 on one page

Mac Games News for Friday, August 8, 2008

Blood Ties Released For Mac OS X2:09 PM
Depths Of Peril Creator Discusses Indie Gaming6:00 AM
Diablo III: Art Director Departs, Possible Cow Level6:00 AM
Eschalon: Book I Reviewed6:00 AM
GameTap Up For Sale6:00 AM
 
View all of the Mac games news for Friday, August 8, 2008 on one page


Recent Mac Games News

Thursday, August 7, 2008
Wednesday, August 6, 2008
Tuesday, August 5, 2008
Monday, August 4, 2008
Friday, August 1, 2008


Search for other Mac games news stories or browse our Mac Games News Archive.



Archives  News  Eschalon Book II: Mac Requirements