Jump to content


Safari won't display youtube full screen anymore.


  • Please log in to reply
24 replies to this topic

#1 the Battle Cat

the Battle Cat

    Carnage Served Raw

  • Admin
  • 17382 posts
  • Location:Citadel City, Lh'owon
  • Pro Member:Yes

Posted 25 December 2015 - 08:36 PM

Safari won't display youtube picture full screen.  The picture stays the same size and moves to the upper left of the display, black fills the remainder the display.  Firefox isn't experiencing this.  

Any suggestions?
Gary Simmons
the Battle Cat

#2 Frigidman™

Frigidman™

    Eye Sea Yew

  • Admin
  • 4265 posts
  • Steam ID:frigidman
  • Location:East mahn, East!
  • Pro Member:Yes

Posted 25 December 2015 - 08:38 PM

Install Chrome ?

Google has long abandoned my Safari, and I have to use the developer tools in it to 'spoof' my user agent to something else that google approves of (chrome). Then everything works correctly. Those jerks ;)

-Fm [1oM7]
"I'm not incorruptible, I am so corrupt nothing you can offer me is tempting." - Alfred Bester


#3 Janichsan

Janichsan

    Jugger Bugger

  • Forum Moderators
  • PipPipPipPipPipPipPipPipPipPipPipPip
  • 8076 posts
  • Steam Name:Janichsan
  • Location:over there

Posted 26 December 2015 - 04:00 AM

View Postthe Battle Cat, on 25 December 2015 - 08:36 PM, said:

Safari won't display youtube picture full screen.  The picture stays the same size and moves to the upper left of the display, black fills the remainder the display.  Firefox isn't experiencing this.  

Any suggestions?
Flash version of the films or HTML5?

"We do what we must, because we can."
"Gaming on a Mac is like women on the internet." — "Highly common and totally awesome?"


#4 the Battle Cat

the Battle Cat

    Carnage Served Raw

  • Admin
  • 17382 posts
  • Location:Citadel City, Lh'owon
  • Pro Member:Yes

Posted 26 December 2015 - 10:11 AM

View PostJanichsan, on 26 December 2015 - 04:00 AM, said:

Flash version of the films or HTML5?

I dunno.  How does one tell the difference?
Gary Simmons
the Battle Cat

#5 Janichsan

Janichsan

    Jugger Bugger

  • Forum Moderators
  • PipPipPipPipPipPipPipPipPipPipPipPip
  • 8076 posts
  • Steam Name:Janichsan
  • Location:over there

Posted 26 December 2015 - 03:17 PM

View Postthe Battle Cat, on 26 December 2015 - 10:11 AM, said:

I dunno.  How does one tell the difference?
When it's Flash, you should see a menu item with "Info about Adobe Flash Player" at the bottom when you right-click on the video.

"We do what we must, because we can."
"Gaming on a Mac is like women on the internet." — "Highly common and totally awesome?"


#6 Thain Esh Kelch

Thain Esh Kelch

    Admin

  • Members
  • PipPipPipPipPipPipPipPip
  • 3783 posts
  • Steam ID:thaineshkelch
  • Location:Denmark

Posted 27 December 2015 - 03:34 AM

I can't get full screen video to play on youtube today using Safari. The video just stops. Going out of full screen doesn't help, as you have to reload the page to get the video to play.
"They're everywhere!" -And now, time for some Legend of Zelda.

iMac 2011, quad 3,4Ghz i7, 1TB Samsung EVO 840, 8GB RAM, 2GB Radeon 6970m. + 2016 Macbook m3 + iPad 2 64GB + iPhone 4S 64GB + Girlfriend + Daughter

#7 the Battle Cat

the Battle Cat

    Carnage Served Raw

  • Admin
  • 17382 posts
  • Location:Citadel City, Lh'owon
  • Pro Member:Yes

Posted 27 December 2015 - 03:44 PM

I tested several videos Janichsan and only found HTML5 vids in my random sample, luck of the draw.  Interestingly, one worked just fine and the others would not expand correctly as originally reported.  So, it seems to me it doesn't make a difference if it's HTML or Flash.
Gary Simmons
the Battle Cat

#8 Janichsan

Janichsan

    Jugger Bugger

  • Forum Moderators
  • PipPipPipPipPipPipPipPipPipPipPipPip
  • 8076 posts
  • Steam Name:Janichsan
  • Location:over there

Posted 28 December 2015 - 11:00 AM

View Postthe Battle Cat, on 27 December 2015 - 03:44 PM, said:

I tested several videos Janichsan and only found HTML5 vids in my random sample, luck of the draw.  Interestingly, one worked just fine and the others would not expand correctly as originally reported.  So, it seems to me it doesn't make a difference if it's HTML or Flash.
Hm, okay. You should make sure you have the recent version of the Flash player anyway (currently 20.0.0.235). You can also try to install the ClickToFlash extension, even if the problem is not directly related to Flash: the extension redirects YouTube videos to the Quicktime plugin, which works usually better for me than YouTube's HTML 5 player.

"We do what we must, because we can."
"Gaming on a Mac is like women on the internet." — "Highly common and totally awesome?"


#9 the Battle Cat

the Battle Cat

    Carnage Served Raw

  • Admin
  • 17382 posts
  • Location:Citadel City, Lh'owon
  • Pro Member:Yes

Posted 28 December 2015 - 02:31 PM

This doesn't seem to be helping.  This seems like such an odd behavior I wonder if something in my system is hosed.  It's been about 15 years since I did a clean install.  When I upgrade to Yosemite I'll do a clean install.  It's a pain in the ass but it needs to be done.  Thanks for the suggestions Janichsan.
Gary Simmons
the Battle Cat

#10 Frigidman™

Frigidman™

    Eye Sea Yew

  • Admin
  • 4265 posts
  • Steam ID:frigidman
  • Location:East mahn, East!
  • Pro Member:Yes

Posted 28 December 2015 - 03:15 PM

Stupid question: Have you done a full reboot since the issue began? I'm not sure how you use your mac, but if you are like me... the actual time between real reboots is in the multitudes of WEEKS ;)

-Fm [1oM7]
"I'm not incorruptible, I am so corrupt nothing you can offer me is tempting." - Alfred Bester


#11 BifBologna

BifBologna

    Heroic

  • Members
  • PipPipPipPip
  • 356 posts
  • Location:Vista, CA

Posted 28 December 2015 - 03:28 PM

I don't think it's your system. I've been experiencing the exact same thing. YouTube videos will not fill the screen in full screen mode in Safari for me. If I open the same video in Opera, it will play full screen just fine. I haven't checked yet to see if Flash is up to date, but I did update it not too long ago so, I'm not too suspicious that that is the problem.

#12 Frigidman™

Frigidman™

    Eye Sea Yew

  • Admin
  • 4265 posts
  • Steam ID:frigidman
  • Location:East mahn, East!
  • Pro Member:Yes

Posted 28 December 2015 - 03:33 PM

Hmm, I'm gonna agree with Bif... cause I just went to youtube in my safari and its now throwing this at me:

Attached File  Screen shot 2015-12-28 at 4.31.15 PM.png   60.7K   11 downloads

This tells me they have done a bunch of stupid nonsense to lock out features and abilities (again) based on the user agent strings. And this can spell disaster if they missed something, or some include file or ability.

-Fm [1oM7]
"I'm not incorruptible, I am so corrupt nothing you can offer me is tempting." - Alfred Bester


#13 Frigidman™

Frigidman™

    Eye Sea Yew

  • Admin
  • 4265 posts
  • Steam ID:frigidman
  • Location:East mahn, East!
  • Pro Member:Yes

Posted 28 December 2015 - 03:40 PM

PS: this is the user agent I parade around in to make google work flawlessly on my 10.6.8 safari mac:
"Mozilla/5.0 (Macintosh; Intel Mac OS X 10_8_5) AppleWebKit/537.78.2 (KHTML, like Gecko) Version/6.1.6 Safari/537.78.2"

-Fm [1oM7]
"I'm not incorruptible, I am so corrupt nothing you can offer me is tempting." - Alfred Bester


#14 DirtyHarry50

DirtyHarry50

    Special Snowflake

  • Members
  • PipPipPipPipPipPip
  • 1515 posts
  • Steam Name:DirtyHarry
  • Steam ID:dirtyharry2
  • Location:North Carolina, USA

Posted 28 December 2015 - 09:52 PM

I finally removed flash from my system entirely the other day. So far, so good. I thought I'd go play some various random You Tube videos and make them full screen with Safari to see what happens and report back here. They all displayed and they all displayed full screen just fine.

I wish Apple would invest more in improving the performance of Safari. It seems slow to load initially and slow to load pages at times even though I have a fast connection. I realize some of that is just internet routing, etc. but it still seems like Safari could really use more work in the optimization department.
“The time you enjoy wasting is not wasted time.” — Bertrand Russell

#15 the Battle Cat

the Battle Cat

    Carnage Served Raw

  • Admin
  • 17382 posts
  • Location:Citadel City, Lh'owon
  • Pro Member:Yes

Posted 29 December 2015 - 10:19 AM

View PostFrigidman™, on 28 December 2015 - 03:15 PM, said:

Stupid question: Have you done a full reboot since the issue began? I'm not sure how you use your mac, but if you are like me... the actual time between real reboots is in the multitudes of WEEKS ;)

That used to be the case for me too but since I installed Boot Camp I'm usually working off of a fresh reboot.

View PostBifBologna, on 28 December 2015 - 03:28 PM, said:

I don't think it's your system. I've been experiencing the exact same thing. YouTube videos will not fill the screen in full screen mode in Safari for me. If I open the same video in Opera, it will play full screen just fine. I haven't checked yet to see if Flash is up to date, but I did update it not too long ago so, I'm not too suspicious that that is the problem.

Why do I feel better that you are suffering too?  Are we still friends?  

View PostFrigidman™, on 28 December 2015 - 03:33 PM, said:

Hmm, I'm gonna agree with Bif... cause I just went to youtube in my safari and its now throwing this at me:

Attachment Screen shot 2015-12-28 at 4.31.15 PM.png

This tells me they have done a bunch of stupid nonsense to lock out features and abilities (again) based on the user agent strings. And this can spell disaster if they missed something, or some include file or ability.

Everything except my OS is up to date, I need to clean install El Capitan but I don't have the time right now.  I'm getting the impression that this is an ongoing problem for Safari and that reports are just now cropping up.
Gary Simmons
the Battle Cat

#16 Frigidman™

Frigidman™

    Eye Sea Yew

  • Admin
  • 4265 posts
  • Steam ID:frigidman
  • Location:East mahn, East!
  • Pro Member:Yes

Posted 29 December 2015 - 10:28 AM

View Postthe Battle Cat, on 29 December 2015 - 10:19 AM, said:

I'm getting the impression that this is an ongoing problem for Safari and that reports are just now cropping up.

Most likely. Chrome has its days too when they push a silent update that starts causing issues. Like some update that made these empty square boxes on random pages at random times of the day... Attached File  Screen shot 2015-11-19 at 5.16.17 PM.png   278.88K   8 downloads

But then suddenly, just as quietly... that bug seems to have disappeared. Or at least it has not shown its ugly head in the last week or two.

Safari gets updates too, webkit mostly (the machine behind it)... which tends to get some unruly changes that dont quite work out. I'm gonna bet theres some hook bug that works haphazardly with full screen mode, and the graphics card. Something aint tripping right.

-Fm [1oM7]
"I'm not incorruptible, I am so corrupt nothing you can offer me is tempting." - Alfred Bester


#17 BifBologna

BifBologna

    Heroic

  • Members
  • PipPipPipPip
  • 356 posts
  • Location:Vista, CA

Posted 29 December 2015 - 09:22 PM

View Postthe Battle Cat, on 29 December 2015 - 10:19 AM, said:

Why do I feel better that you are suffering too?  Are we still friends?

Sure. Buds for life.

Posted Image

In fact, you should come play Insurgency with me, like my "friend" Stealth_Moose did...

https://youtu.be/ZKnuq_7Bgv4

#18 the Battle Cat

the Battle Cat

    Carnage Served Raw

  • Admin
  • 17382 posts
  • Location:Citadel City, Lh'owon
  • Pro Member:Yes

Posted 30 December 2015 - 10:30 AM

View PostFrigidman™, on 29 December 2015 - 10:28 AM, said:

Most likely. Chrome has its days too when they push a silent update that starts causing issues. Like some update that made these empty square boxes on random pages at random times of the day... Attachment Screen shot 2015-11-19 at 5.16.17 PM.png

But then suddenly, just as quietly... that bug seems to have disappeared. Or at least it has not shown its ugly head in the last week or two.

Safari gets updates too, webkit mostly (the machine behind it)... which tends to get some unruly changes that dont quite work out. I'm gonna bet theres some hook bug that works haphazardly with full screen mode, and the graphics card. Something aint tripping right.

Overheard at Apple: "Aw hell just release the build, what could go wrong?  It works great on our computers... come on boss, just OK it and let's get the damn thing out the door on time for once."

View PostBifBologna, on 29 December 2015 - 09:22 PM, said:

Sure. Buds for life.

Posted Image

In fact, you should come play Insurgency with me, like my "friend" Stealth_Moose did...

https://youtu.be/ZKnuq_7Bgv4

I just cant fault you for baiting a guy named "Baiting_Moose", but you still have to wear the ass hat for the next hour.
Gary Simmons
the Battle Cat

#19 BifBologna

BifBologna

    Heroic

  • Members
  • PipPipPipPip
  • 356 posts
  • Location:Vista, CA

Posted 30 December 2015 - 02:38 PM

View Postthe Battle Cat, on 30 December 2015 - 10:30 AM, said:

I just cant fault you for baiting a guy named "Baiting_Moose", but you still have to wear the ass hat for the next hour.

And, I shall wear it with pride ;)

#20 the Battle Cat

the Battle Cat

    Carnage Served Raw

  • Admin
  • 17382 posts
  • Location:Citadel City, Lh'owon
  • Pro Member:Yes

Posted 24 February 2016 - 09:57 AM

My problem has suddenly and inexplicably solved itself.  Safari now displays Youtube vids full screen.
Gary Simmons
the Battle Cat