Jump to content


I'm all outta bubblegum and shurikens too.


  • Please log in to reply
5 replies to this topic

#1 DirtyHarry50

DirtyHarry50

    Special Snowflake

  • Members
  • PipPipPipPipPipPip
  • 1515 posts
  • Steam Name:DirtyHarry
  • Steam ID:dirtyharry2
  • Location:North Carolina, USA

Posted 29 October 2015 - 02:32 AM

Tonight I fired up Duke Megaton Edition and Shadow Warrior Redux, both made by the same people and setup the same way pretty much as OpenGL source ports of these games which also include the classic versions running in DOSBox.

Well, for some odd reason while my Logitech Performance Mouse MX wireless always works like a charm gaming and elsewhere, mouse look which should be enabled by default in both games and appears to be in settings just won't work. The funny thing is in both cases when I fire up the classic versions with DOSBox, mouse look works just fine for them. Try to go with the fancy modern look and no joy for me.

Any ideas? I tried messing with settings to no avail although there are precious few mouse settings anyway. I checked keyboard settings too but nothing there. I tried deleting the config files so on launch they would generate fresh new ones which they both did but no change.

My mouse just won't work! It just won't do it.

On a bright note, I checked into eDuke32, downloaded the most recent OS X build which just happened to be only a couple weeks old roughly and what a cool app it is. It actually had the smarts to find my Duke Megaton game assets for me so I didn't have to monkey around moving stuff into the app or whatever. It just locates them on its own, opens a launcher serving up the choices which for Megaton number 4 exciting action filled packs of fun and you pick one and you're off! It is truly a beautiful thing. If only they did one for Shadow Warrior but alas I can hardly complain about that with the excellent work they did on eDuke.

If I must get my wang on in classic mode so be it because I am not dealing without mouse look.
“The time you enjoy wasting is not wasted time.” — Bertrand Russell

#2 MichalM.Mac

MichalM.Mac

    Heroic

  • Members
  • PipPipPipPip
  • 263 posts
  • Steam Name:michalmmac
  • Steam ID:michalmmac

Posted 29 October 2015 - 03:31 AM

One does not simply play Duke Nukem with a mouselook!

#3 the Battle Cat

the Battle Cat

    Carnage Served Raw

  • Admin
  • 17377 posts
  • Location:Citadel City, Lh'owon
  • Pro Member:Yes

Posted 29 October 2015 - 09:15 AM

I have Steam's dosbox version of Shadow warrior.  Unplayable due to mouse issues.
Gary Simmons
the Battle Cat

#4 Janichsan

Janichsan

    Jugger Bugger

  • Forum Moderators
  • PipPipPipPipPipPipPipPipPipPipPipPip
  • 8075 posts
  • Steam Name:Janichsan
  • Location:over there

Posted 29 October 2015 - 09:51 AM

View PostDirtyHarry50, on 29 October 2015 - 02:32 AM, said:

Tonight I fired up Duke Megaton Edition and Shadow Warrior Redux, both made by the same people and setup the same way pretty much as OpenGL source ports of these games which also include the classic versions running in DOSBox.

Well, for some odd reason while my Logitech Performance Mouse MX wireless always works like a charm gaming and elsewhere, mouse look which should be enabled by default in both games and appears to be in settings just won't work. The funny thing is in both cases when I fire up the classic versions with DOSBox, mouse look works just fine for them. Try to go with the fancy modern look and no joy for me.

Any ideas? I tried messing with settings to no avail although there are precious few mouse settings anyway. I checked keyboard settings too but nothing there. I tried deleting the config files so on launch they would generate fresh new ones which they both did but no change.

My mouse just won't work! It just won't do it.

Have you checked the mouse sensitivity settings? I recall that the default in DN3D:MTE was for some reason set to zero for me.

"We do what we must, because we can."
"Gaming on a Mac is like women on the internet." — "Highly common and totally awesome?"


#5 DirtyHarry50

DirtyHarry50

    Special Snowflake

  • Members
  • PipPipPipPipPipPip
  • 1515 posts
  • Steam Name:DirtyHarry
  • Steam ID:dirtyharry2
  • Location:North Carolina, USA

Posted 29 October 2015 - 11:25 AM

Double checked settings and then altered them in various ways testing each time and no change whatsoever. I even tried turning off the few additional buttons this mouse has just to make sure it was not somehow creating a problem but that not surprisingly made no difference either. i'll try anything when I am brainstorming though. I made a post in the game's Steam forum (just Shadow Warrior) and maybe somebody else there has seen this issue.

I'm golden with the Duke. As for Lo Wang, I guess we may be going retro classic mode there if no luck sorting this which is hardly the end of the world anyway. The OpenGL versions are nicer but oh, well.
“The time you enjoy wasting is not wasted time.” — Bertrand Russell

#6 Thain Esh Kelch

Thain Esh Kelch

    Admin

  • Members
  • PipPipPipPipPipPipPipPip
  • 3783 posts
  • Steam ID:thaineshkelch
  • Location:Denmark

Posted 30 October 2015 - 07:04 AM

Man, I was so awesome in Marathon multiplayer using keyboard only. How I was able to move with the numberpad, and look with arrow keys at the same time using one hand, and still own, is now beyond me. I must have lost a few extra fingers since I was a kid.
"They're everywhere!" -And now, time for some Legend of Zelda.

iMac 2011, quad 3,4Ghz i7, 1TB Samsung EVO 840, 8GB RAM, 2GB Radeon 6970m. + 2016 Macbook m3 + iPad 2 64GB + iPhone 4S 64GB + Girlfriend + Daughter