Jump to content


Speed up Finder initial load by blocking Time Machine?

automountd mavericks 10.9 finder slow block little snitch backups backupdb

  • Please log in to reply
5 replies to this topic

#1 UmarOMC1

UmarOMC1

    Legendary

  • Members
  • PipPipPipPipPip
  • 1439 posts
  • Location:NYC

Posted 12 December 2013 - 10:27 PM

So I've Little Snitch and have come to accept that the first time I request a Finder window after upgrading to 10.9 it takes quite awhile to finish up loading. Having the Network Monitor in the Menubar I noticed while the Finder was working on this initial Finder window draw request, there were concurrent outgoing bits of data shooting out, showing the full list of apps that chronologically make network connections I found it was a process called automountd. After a little Googling I have come to believe that this is the IP and port (backups.backupdb port 111) used to communicate with a networked Time Machine volume. I initially allowed it through Little Snitch because it's a system process. I block it, reboot, Finder is almost instantaneous again! I don't use Time Machine so I also can't test the repercussions but I assume I wouldn't be allowed to communicate/utilize a networked Time Machine volume.
macOS 10.13.x/Windows 7 Pro/2009 MacPro 4,1 Xeon W3580 3.33GHz/16GB RAM/EVGA GTX1070 8GB

#2 the Battle Cat

the Battle Cat

    Carnage Served Raw

  • Admin
  • 17431 posts
  • Location:Citadel City, Lh'owon
  • Pro Member:Yes

Posted 13 December 2013 - 09:06 AM

How do I do this in Little Snitch?  Open the rules from the menu bar, create a new rule,  in the "From process" enter "backups.backupdb", enter "111" in the port box, and then at the top "deny connections" would be my guess but I've never set up a block from scratch, just as a connect gets reported.  Normally I let anything Apple do whatever it wants, so I must have OKed it, but I can't find the rule.
Gary Simmons
the Battle Cat

#3 Frigidman™

Frigidman™

    Eye Sea Yew

  • Admin
  • 4265 posts
  • Steam ID:frigidman
  • Location:East mahn, East!
  • Pro Member:Yes

Posted 13 December 2013 - 12:23 PM

It amazes me after how many years now, that apple still has the finder basically 'hang' when it cannot find something over a network that it wanted. From this above, to smb, to appleshares on your home network... just amazes me.

-Fm [1oM7]
"I'm not incorruptible, I am so corrupt nothing you can offer me is tempting." - Alfred Bester


#4 Frost

Frost

    Secretary of Offense

  • Forum Moderators
  • PipPipPipPipPipPipPipPipPipPipPip
  • 6094 posts
  • Steam ID:CaptFrost
  • Location:Republic of Texas
  • Pro Member:Yes

Posted 13 December 2013 - 02:09 PM

Weird... whenever my Macs can't communicate with my NAS for one reason or another the Time Machine icon just turns to an exclamation point. Never had a hang on startup.

I don't exactly run Time Machine vanilla though. I don't need every machine flooding the network with useless traffic every hour, so I used MacPilot to dial back the backup intervals to every 24 hours. Wish Apple had the sense to let you adjust that with a slider or something from the control panel.
Kestrel (Falcon NW Tiki) – 4.0 GHz i7 4790K / 16GB RAM / 512GB Samsung 950 Pro M.2, 2x480GB Intel 730 (RAID0), 10TB STX BarraCuda Pro / GeForce GTX TITAN X 12GB
Iridium (MacBook Pro Mid-2012) – 2.7 GHz i7 3820QM / 16GB RAM / 2TB Samsung 850 Pro / GeForce GT 650M 1GB

Eric5h5:
When there's a multiplayer version, I'm going to be on Frost's team. Well, except he doesn't seem to actually need a team...I mean, what's the point? "Hey look, it's Frost and His Merry Gang of Useless Hangers-On!" Or something.

#5 UmarOMC1

UmarOMC1

    Legendary

  • Members
  • PipPipPipPipPip
  • 1439 posts
  • Location:NYC

Posted 13 December 2013 - 10:46 PM

View Postthe Battle Cat, on 13 December 2013 - 09:06 AM, said:

How do I do this in Little Snitch?  Open the rules from the menu bar, create a new rule,  in the "From process" enter "backups.backupdb", enter "111" in the port box, and then at the top "deny connections" would be my guess but I've never set up a block from scratch, just as a connect gets reported.  Normally I let anything Apple do whatever it wants, so I must have OKed it, but I can't find the rule.

Since it's a login process Little Snitch created a rule set for me to peruse and edit initially allowing it. Showing All Rules (upper left) I scroll down the alphabetically listed rulesets to automountd double click or right-click and choose Edit Rule... change Allow Connections to Deny Connections.
macOS 10.13.x/Windows 7 Pro/2009 MacPro 4,1 Xeon W3580 3.33GHz/16GB RAM/EVGA GTX1070 8GB

#6 the Battle Cat

the Battle Cat

    Carnage Served Raw

  • Admin
  • 17431 posts
  • Location:Citadel City, Lh'owon
  • Pro Member:Yes

Posted 14 December 2013 - 11:48 AM

I don't have a automountd rule, but then I've disabled Time Machine before I upgraded to Mavericks and when upgrading, I once again refused Time Machine.  Probably why I didn't notice anything hanging, but still wanted to disable anything related to Time Machine.  Thanks, what you told me did help resolve my problem finding the rule.
Gary Simmons
the Battle Cat





Also tagged with one or more of these keywords: automountd, mavericks, 10.9, finder, slow, block, little snitch, backups, backupdb