Jump to content


Can't Connect to Mac App Store Fix


  • Please log in to reply
No replies to this topic

#1 Frost

Frost

    PowerPC Inside

  • Forum Moderators
  • PipPipPipPipPipPipPipPipPip
  • 4933 posts
  • Steam ID:CaptFrost
  • Location:Republic of Texas
  • Pro Member:Yes

Posted 23 November 2012 - 07:41 PM

Run into this problem intermittently or constantly? You try to connect to the Mac App Store but it insists there's something wrong with your internet connection. You know there isn't, but everything you can find about it, including Apple's own documentation, tries to troubleshoot your connection.

You're not the only one. It seemed to go away on its own for a couple instances, but one was completely persistent: my mom's 2010 Mac mini 2.66. Tried everything to fix it for her a couple times in the past two weeks when I had the chance and nothing worked, even a clean install. Finally came across this online, and that did the trick. Apparently, there was a bug in 10.7.4 that can mess up the System Root certificates, and it carries over clear up to 10.8.2 if you never fixed it manually.

I spent about 30 minutes last night manually changing certificate settings until nothing was listed as custom anymore, and presto, Mac App Store is again functional.

Here's what I used:

Quote

quickSti wrote:



I solved this on my wife's computer by resetting the security certificate settings.  This might help others:


Close all windows.



Keychain Access ->  click on System Roots on the left, and then click on Certifcates on the bottom left.



Check to see if any of the certificates on the right have the blue "+" symbol - this means they have custom trust settings.



There is a bug in changing the policies, so you'll have to change them via the method below.  Changing them just by changing the access to "system defaults" doesn't seem to save.  The method below worked for me.



Double-click on each certificate with the custom setting (blue "+"), expand the section labled "trust".  Change the "Secure Sockets Layer (SSL)" setting to "no value specified".  Close window - you should be prompted for the password.  Double-click on the certificate again, expand trust, change the "When using this certificate" setting to "Use System Defaults".  Close window, and re-enter password.



If you didn't re-enter your password upon closing the window, the setting didn't take.  The blue "+" should disappear after a few seconds when it's set back to default.  Once all of the certificates are changed back to default, restart Safari.



This solved all of the problems for my wife's computer with these issues and OSX 10.7.4



Cypher (PowerMac G5 Quad) – 2x2.5 GHz PPC 970MP / 16GB ECC RAM / 1TB WDC Velociraptor, 2TB STX Constellation ES.2 / QuadroFX 4500 512MB
Kestrel (Falcon NW Tiki) – 4.2 GHz Ci7 4770K / 16GB RAM / 512GB Crucial M550 M.2, 3TB STX Barracuda / GeForce GTX TITAN 6GB
Chromium (MacBook Pro Early 2008) – 2.6 GHz C2D T9500 / 4GB RAM / 960GB Crucial M500 / GeForce 8600M GT 512MB
Antimony (PowerBook G4 Titanium) – 1.0 GHz PPC 7455 / 1GB RAM / 480GB OWC Mercury Legacy Pro / Radeon 9000 64MB

Eric5h5:
When there's a multiplayer version, I'm going to be on Frost's team. Well, except he doesn't seem to actually need a team...I mean, what's the point? "Hey look, it's Frost and His Merry Gang of Useless Hangers-On!" Or something.