Jump to content


CrossOver Games Compatibility


  • Please log in to reply
147 replies to this topic

#141 Janichsan

Janichsan

    Jugger Bugger

  • Forum Moderators
  • PipPipPipPipPipPipPipPipPipPipPipPip
  • 8076 posts
  • Steam Name:Janichsan
  • Location:over there

Posted 08 August 2014 - 10:27 AM

I understand correctly you are running Giants in a Wine wrapper? Have you played around with the Screen Options, e.g. switching from "Rootless (windowed)" to "Fullscreen" and/or "Use Mac Driver instead of X11"? And if still nothing helps but running the game on a virtual desktop, how about making that virtual desktop so big it's the same size as your actual desktop? You would at least reduce the chance of clicking outside the window significantly.

"We do what we must, because we can."
"Gaming on a Mac is like women on the internet." — "Highly common and totally awesome?"


#142 Matt Diamond

Matt Diamond

    Master Blaster

  • IMG Writers
  • 2453 posts
  • Location:Holland, PA; US
  • Pro Member:Yes

Posted 08 August 2014 - 02:47 PM

Thanks for the suggestions.
* I was forced to use virtual desktop; I get serious video problems otherwise.
* Making it the same size: my monitor's aspect ratio is apparently not compatible with what this game supports. And instead letterboxng, the window shrinks horizontally to fit, leaving the desktop uncovered.

Mac Driver: good idea, I will try that.
Matt Diamond - www.mindthecube.com
Measure twice, cut once, curse three or four times.

#143 doh123

doh123

    Wineskin

  • Developer
  • PipPipPip
  • 165 posts

Posted 08 August 2014 - 06:31 PM

In Wineskin... if you use WineskinX11, along with override->fullscreen.... it runs Wine in a virtual desktop, drawn on an X11 fullscreen.  So if your game works in a virtual desktop, it should work in override->fullscreen, as long as your using a resolution in the game that is supported by your display.

#144 Matt Diamond

Matt Diamond

    Master Blaster

  • IMG Writers
  • 2453 posts
  • Location:Holland, PA; US
  • Pro Member:Yes

Posted 08 August 2014 - 09:02 PM

I appreciate everyone's efforts.

I'm sorry to report it does not work in fullscreen mode. The screen flickers crazily, and the last frame of whatever cutscene last played stays visible, superimposed over the gameplay.

I tried some other stuff I won't go into that didn't work. But I think I've got it now - I had to turn off the decorate windows option. The resolution it runs in still doesn't match the monitor's, but now it fills the rest of the screen with black instead of showing the desktop. Whew! There are small downsides (I can't seem to hide the window to return to it later, so I have to sit through the interminable loading screens every time) but it's playable now.

Thanks again, everybody!
Matt Diamond - www.mindthecube.com
Measure twice, cut once, curse three or four times.

#145 doh123

doh123

    Wineskin

  • Developer
  • PipPipPip
  • 165 posts

Posted 08 August 2014 - 11:39 PM

View PostMatt Diamond, on 08 August 2014 - 09:02 PM, said:

I appreciate everyone's efforts.

I'm sorry to report it does not work in fullscreen mode. The screen flickers crazily, and the last frame of whatever cutscene last played stays visible, superimposed over the gameplay.

I tried some other stuff I won't go into that didn't work. But I think I've got it now - I had to turn off the decorate windows option. The resolution it runs in still doesn't match the monitor's, but now it fills the rest of the screen with black instead of showing the desktop. Whew! There are small downsides (I can't seem to hide the window to return to it later, so I have to sit through the interminable loading screens every time) but it's playable now.

Thanks again, everybody!
Unless you are using the Mac Driver... CMD+Enter should knock it out of captured full screen.  Then select the app and do the same key combo to knock it back in captured full screen.

#146 Matt Diamond

Matt Diamond

    Master Blaster

  • IMG Writers
  • 2453 posts
  • Location:Holland, PA; US
  • Pro Member:Yes

Posted 09 August 2014 - 09:34 PM

View Postdoh123, on 08 August 2014 - 11:39 PM, said:

Unless you are using the Mac Driver... CMD+Enter should knock it out of captured full screen.  Then select the app and do the same key combo to knock it back in captured full screen.
That seems to work- thanks!

View PostMatt Diamond, on 08 August 2014 - 09:02 PM, said:

I'm sorry to report it does not work in fullscreen mode. [..]
I think I've got it now - I had to turn off the decorate windows option.
This "tip" appears to be wrong. When I turn off decorate windows, I see now that setting doesn't seem to stick (it's on again the next time I check it.)
Furthermore, virtual desktop still does not cover the real desktop.

OTOH fullscreen mode is now working, though not as it did before. The gameplay is in the upper left of the monitor, not centered. But the flickering and video problems are gone. The only thing I remember doing was switching to the Wine engine 1.6.x, finding it wouldn't run the game, and then switching back to 1.7.23. Either that fixed it, or I changed some other setting along the way that I don't recall.

Lesson learned: when WINE works its a thing of beauty but it can suck up lots of time being fiddly.
Matt Diamond - www.mindthecube.com
Measure twice, cut once, curse three or four times.

#147 doh123

doh123

    Wineskin

  • Developer
  • PipPipPip
  • 165 posts

Posted 10 August 2014 - 09:26 AM

View PostMatt Diamond, on 09 August 2014 - 09:34 PM, said:

This "tip" appears to be wrong. When I turn off decorate windows, I see now that setting doesn't seem to stick (it's on again the next time I check it.)
Furthermore, virtual desktop still does not cover the real desktop.

OTOH fullscreen mode is now working, though not as it did before. The gameplay is in the upper left of the monitor, not centered. But the flickering and video problems are gone. The only thing I remember doing was switching to the Wine engine 1.6.x, finding it wouldn't run the game, and then switching back to 1.7.23. Either that fixed it, or I changed some other setting along the way that I don't recall.

Lesson learned: when WINE works its a thing of beauty but it can suck up lots of time being fiddly.
Almost all the Settings only work with WineskinX11... if your using the Mac Driver or XQuartz, many will not work... I really need to update that to gray things out properly...

If its running in the top left corner, then the game is requesting a resolution that your machine cannot run, so its doing the best it can... maybe try different in game resolution settings, and find one your machine can run.

#148 Matt Diamond

Matt Diamond

    Master Blaster

  • IMG Writers
  • 2453 posts
  • Location:Holland, PA; US
  • Pro Member:Yes

Posted 11 August 2014 - 02:15 PM

View Postdoh123, on 10 August 2014 - 09:26 AM, said:

Almost all the Settings only work with WineskinX11... if your using the Mac Driver or XQuartz, many will not work...
Good to know. I'm definitely not using the Mac driver, I only tried that once. I'll double-check the XQuartz setting-- I have XQuartz installed but I don't believe I told Wineskin to use it. However, as we've already seen I don't always remember what I've set..

Quote

If its running in the top left corner, then the game is requesting a resolution that your machine cannot run, so its doing the best it can... maybe try different in game resolution settings, and find one your machine can run.

Again, good to know. I'm not convinced there is a resolution the game and monitor both like but it's no big deal, I'm just happy the desktop is completely covered.

Since it seems like I'm always complaining, let me just state outright that while Wine is great, WineSkin is for me the only thing that makes messing with Wine tolerable. It's doing a lot for me and I forgive it a hundred times over for any shortcomings. I'm not sure whether you are solo on that, or the wrangler for a team of volunteers, but thank you!
Matt Diamond - www.mindthecube.com
Measure twice, cut once, curse three or four times.