Jump to content


The Sims 2 has a file limit


  • Please log in to reply
111 replies to this topic

#101 Tesseract

Tesseract

    Unmanageable Megaweight

  • Members
  • PipPipPipPipPipPipPipPip
  • 3512 posts
  • Pro Member:Yes

Posted 08 September 2005 - 12:56 AM

The settings will be reset when you restart, but that's just the way sysctl works, it's not because you used sudo. The sudo command is a tool which allows admin users to do things which are normally protected.

#102 luws

luws

    Fanatic

  • Members
  • PipPip
  • 105 posts

Posted 08 September 2005 - 09:24 AM

Oh, then is there a way to make these changes permanent? In the etc/rc file perhaps? Would it be dangerous to do?

#103 Tesseract

Tesseract

    Unmanageable Megaweight

  • Members
  • PipPipPipPipPipPipPipPip
  • 3512 posts
  • Pro Member:Yes

Posted 09 September 2005 - 02:01 AM

/etc/rc.local would be the appropriate place. Increasing the file limit there shouldn't be dangerous, but as always I strongly recommend that you make sure you really know what you are doing before modifying anything in /etc. You won't need to use sudo in an rc script BTW, since they run as the superuser anyway.

#104 luws

luws

    Fanatic

  • Members
  • PipPip
  • 105 posts

Posted 10 September 2005 - 12:28 AM

Tesseract, on September 9th 2005, 01:01 AM, said:

/etc/rc.local would be the appropriate place. Increasing the file limit there shouldn't be dangerous, but as always I strongly recommend that you make sure you really know what you are doing before modifying anything in /etc. You won't need to use sudo in an rc script BTW, since they run as the superuser anyway.

View Post

Yes, I am fearful of messing something up, that is why I am posting. But I did go through this a few yrs. back with Sims 1 file limits and it worked fine. As I recall, when you are in the etc/rc file, you amend what's there, correct? I would not be entering the above lines, but instead would be finding & replacing  those lines in etc/rc.local with the numbers I want??

I'm trying to be "sure I really know what I'm doing" but every little detail you can supply to help would be very much appreciated. I'm good at following instructions, so the more details the better.

#105 Tesseract

Tesseract

    Unmanageable Megaweight

  • Members
  • PipPipPipPipPipPipPipPip
  • 3512 posts
  • Pro Member:Yes

Posted 10 September 2005 - 08:08 AM

/etc/rc.local probably doesn't exist unless you have created it yourself. If it does exist, then yes, you want to edit it, not replace it. You can get to /etc in the Finder using the "Go to Folder..." command in the Go menu. If there is an rc.local there, then open it with TextEdit. (If double-clicking doesn't work, just drag the file to TextEdit's icon in the dock.)

If rc.local doesn't exist yet, create a new file in TextEdit, choose "Make Plain Text" from the format menu, and then "Save As...". In the save dialog box, uncheck the "If no extension is provided, use .txt" check box. Navigate to /etc by typing "/etc" in the search box at the top right of the dialog box. Then enter "rc.local" as the file name and click Save.

You should now have an /etc/rc.local file open in TextEdit. Enter these two lines at the end of the file:

sysctl -w kern.maxfiles=22000
sysctl -w kern.maxfilesperproc=20000

Then save and quit. The commands should now run at startup. You can check if it works by rebooting then running "sysctl kern.maxfiles" and "sysctl kern.maxfilesperproc" in Terminal -- these commands will display the current values of the file limits.

#106 luws

luws

    Fanatic

  • Members
  • PipPip
  • 105 posts

Posted 10 September 2005 - 08:23 PM

Thanks so much Tesseract, I'll let you know  how it goes. I may not get the nerve up to try it for a few days.

It's different than a few yrs. ago with Sims 1. Back then, I accessed etc/rc in Terminal, and made changes. I tried it that way a few months ago when Sims2 first came out, but Terminal didn't understand. So this clears that up. Now it's a local file.

thanks again!

#107 luws

luws

    Fanatic

  • Members
  • PipPip
  • 105 posts

Posted 10 September 2005 - 09:06 PM

Success!!! :D
Thanks so much for the guidance Tesseract! It worked great! :P
I decided not to put off trying it... ;)

I'm so happy, thank you, thank you thank you! :lol:

#108 Tesseract

Tesseract

    Unmanageable Megaweight

  • Members
  • PipPipPipPipPipPipPipPip
  • 3512 posts
  • Pro Member:Yes

Posted 11 September 2005 - 11:28 PM

Good to hear. Enjoy using your tens of thousands of Sims 2 mods. ;)

#109 fluffyemu

fluffyemu

    Newbie

  • Members
  • 2 posts

Posted 02 January 2006 - 09:42 PM

I'm not sure what I did wrong, but the process one doesn't seem to be changing. I made the rc.local file  and c/ped your commands, but when I use the terminal to check after restart I get this:

emu12:~ Rachel$ sysctl kern.maxfiles
kern.maxfiles = 22000
emu12:~ Rachel$ sysctl kern.maxfilesperproc
kern.maxfilesperproc = 10240


My rc.local file says this:

sysctl -w kern.maxfiles=22000
sysctl -w kern.maxfilesperproc=20000

What am I doing wrong?

#110 Tesseract

Tesseract

    Unmanageable Megaweight

  • Members
  • PipPipPipPipPipPipPipPip
  • 3512 posts
  • Pro Member:Yes

Posted 02 January 2006 - 11:08 PM

I have no idea. If you copied and pasted from your rc.local, it looks right. Are there any error messages in your system.log or console.log that might be related? Does the maxfilesperproc value "stick" if you set it in the Terminal?

#111 fluffyemu

fluffyemu

    Newbie

  • Members
  • 2 posts

Posted 04 January 2006 - 04:24 AM

If I try to set it in terminal, this happens:

emu12:~ Rachel$ sudo sysctl -w kern.maxfiles=22000
sudo: /private/etc/sudoers is mode 0644, should be 0440
emu12:~ Rachel$ postdrop: warning: unable to look up public/pickup: No such file or directory
sudo sysctl -w kern.maxfilesperproc=20000
sudo: /private/etc/sudoers is mode 0644, should be 0440
emu12:~ Rachel$ postdrop: warning: unable to look up public/pickup: No such file or directory

#112 Tesseract

Tesseract

    Unmanageable Megaweight

  • Members
  • PipPipPipPipPipPipPipPip
  • 3512 posts
  • Pro Member:Yes

Posted 04 January 2006 - 07:14 PM

Try repairing permissions in Disk Utility.