Jump to content

iOS 6 Music App search feature/organization bugged

  • Please log in to reply
2 replies to this topic

#1 Tetsuya


    Master Blaster

  • Members
  • PipPipPipPipPipPip
  • 2195 posts
  • Location:MI

Posted 27 December 2012 - 10:56 PM

The first time this happened after the update I noticed that some songs were not coming up in the search but then I noticed that if I selected one of the songs that were coming up, it played something entirely different.

I deleted all the music from the device, and did a complete restore. Synced the music again and had the same result. Only that now, the song list is in disorder for example I would get:


Anna Begins

August and everything after


Benjamin Lawrence



I restored the iPad and did the sync again, but did it as a new device, same result. Since my screen was also had some problems, I took advance of the warranty and sent it for repair. I received the new device yesterday. Did a set up, updated to iOS6 once again and synced my library. Same Issue.

see more info in this thread:


I do h ave a lot of music (about ~19GB when converted to 128kbps AAC for storage on the iPad).

Curious if anyone else is having this issue.  

Songs wont show up in search, no matter how you search for them, even though they are on the iPad and can be played if you can manage to track them down in the strangely out-of-order music list (i have the exact problem shown above).  

#2 AussieMacGamer


    Owner, 2nd Largest Topic

  • Members
  • PipPipPipPipPipPipPip
  • 3087 posts

Posted 28 December 2012 - 09:46 AM

open the library on another user account/computer, and sync it again

IMG Resident Crackpot
"What you need is a dog or a girlfriend, or both, or one in the same!" -Gary Simmons Aka. The Battle Cat
15" Macbook Pro C2D 2.16Ghz ATI X1600 3Gb Ram w/Samsung 840 SSD R.I.P

2015 Mbp 13", 256gb SSD

Windows popsnizzlebox with a 5400rpm HD and a GTX 1060

Now Playing: Player Unknown's Battlegrounds/CS:GO/Rising Storm 2/The Witcher 3 Blood and Wine/Shenmue 1

#3 Tetsuya


    Master Blaster

  • Members
  • PipPipPipPipPipPip
  • 2195 posts
  • Location:MI

Posted 28 December 2012 - 05:52 PM

I assume you meant hold down Option while starting iTunes on another computer, and selecting my library (by "opening the library on another computer") - which i tried out.

Didn't seem to do anything.  Still having all of the same problems.  Thanks for the idea, though.