Jump to content


Black Ops 3 update broke multiplayer

fyi broken cod aspyr

  • Please log in to reply
3 replies to this topic

#1 UmarOMC1

UmarOMC1

    Master Blaster

  • Members
  • PipPipPipPipPipPip
  • 1591 posts
  • Location:NYC

Posted 14 January 2020 - 11:28 PM

After rebooting my router twice, cable modem once (much to the chagrin of my kids) I decide to peruse the Steam Discussions and, at least according to the posts to one thread, a big update was applied PC-side that for some has broken multiplayer for now.

Yay.

I guess now I'm left holding my breath for the update macOS-side.
macOS 10.15.x/3.5GHZ 8-Core Xeon W-3223 2019 MacPro/32GB RAM/Gigabyte RADEON VII

macOS 10.15.x/3.7GHz i7-8700K Hackintosh/64GB RAM/PowerColor RedDevil 5700XT
(my 'world of hurt' that my kids built in a day & is easier to maintain than Windows)

macOS 10.14.x/3.33GHz Xeon W3580 cMacPro (5,1 flash)/64GB RAM/PowerColor RedDevil RX580

#2 UmarOMC1

UmarOMC1

    Master Blaster

  • Members
  • PipPipPipPipPipPip
  • 1591 posts
  • Location:NYC

Posted 16 January 2020 - 03:31 PM

Okay, apparently Treyarch have pulled this before. This is the exact issue I'm having. I thought it was because my NAT type was 'moderate,' I have no hair left to pull out in troubleshooting my network but got the NAT type to 'open,' no avail, same shyzz. Of course I started with the run-of-the-mill rebooting the router, setting up my computer's IP for a DMZ, cable modem, computer, renewing DHCP lease and went on to factory resetting the router. I can't see how this is possibly on my end.

I submitted a couple of times to Aspyr Support and, well, is anyone else having issues signing in to Aspyr Support? I keep getting "INCORRECT EMAIL OR PASSWORD," have tried submitting as if I've forgotten my password but get no email. :cool:
macOS 10.15.x/3.5GHZ 8-Core Xeon W-3223 2019 MacPro/32GB RAM/Gigabyte RADEON VII

macOS 10.15.x/3.7GHz i7-8700K Hackintosh/64GB RAM/PowerColor RedDevil 5700XT
(my 'world of hurt' that my kids built in a day & is easier to maintain than Windows)

macOS 10.14.x/3.33GHz Xeon W3580 cMacPro (5,1 flash)/64GB RAM/PowerColor RedDevil RX580

#3 UmarOMC1

UmarOMC1

    Master Blaster

  • Members
  • PipPipPipPipPipPip
  • 1591 posts
  • Location:NYC

Posted 23 January 2020 - 09:46 PM

I'm sorry but does anyone here play this game online and might be having similar problems?

EDIT: Scratch the response. I signed up for Activision's forums and see people on different platforms are experiencing the same shyzz. I opened a ticket but am expecting shyzz as well.
macOS 10.15.x/3.5GHZ 8-Core Xeon W-3223 2019 MacPro/32GB RAM/Gigabyte RADEON VII

macOS 10.15.x/3.7GHz i7-8700K Hackintosh/64GB RAM/PowerColor RedDevil 5700XT
(my 'world of hurt' that my kids built in a day & is easier to maintain than Windows)

macOS 10.14.x/3.33GHz Xeon W3580 cMacPro (5,1 flash)/64GB RAM/PowerColor RedDevil RX580

#4 UmarOMC1

UmarOMC1

    Master Blaster

  • Members
  • PipPipPipPipPipPip
  • 1591 posts
  • Location:NYC

Posted 12 February 2020 - 08:19 PM

I'm thinking maybe 4 people bought the macOS version or only I'm experiencing this right now. Did you know that five days after my last post Activision shut down their Community Forums? lol
macOS 10.15.x/3.5GHZ 8-Core Xeon W-3223 2019 MacPro/32GB RAM/Gigabyte RADEON VII

macOS 10.15.x/3.7GHz i7-8700K Hackintosh/64GB RAM/PowerColor RedDevil 5700XT
(my 'world of hurt' that my kids built in a day & is easier to maintain than Windows)

macOS 10.14.x/3.33GHz Xeon W3580 cMacPro (5,1 flash)/64GB RAM/PowerColor RedDevil RX580





Also tagged with one or more of these keywords: fyi, broken, cod, aspyr