Jump to content


Majesty


  • Please log in to reply
1 reply to this topic

#1 Ganoen

Ganoen

    Fanatic

  • Members
  • PipPip
  • 120 posts
  • Location:Eastern US

Posted 01 October 2004 - 09:26 AM

Here's an old one...Majesty. Normally, it works fine in Classic mode (minus the CD soundtrack). Recently, though, the sound has been acting a little weird. Everything sounds higher pitched and faster, as if the sounds were playing too fast.

I've been racking my brain trying to figure out what I've changed since the last time I ran it, but I'm just not sure since it's been awhile. I did notice one thing: I recently changed to a new monitor, which runs natively at 1280x1024. If I launch Majesty from that setting, things sound especially sped-up. If I switch to 1024x768 first, things sound better though still too fast. Could monitor resolution on launch really affect sound speed?

As a side note: Whatever happened to Majesty 2? I seem to remember screenshots getting posted like...2 years ago or so. Was that a hoax or did the company die?

#2 Rubel

Rubel

    Legendary

  • Members
  • PipPipPipPipPip
  • 914 posts
  • Location:Mountain View, HI

Posted 01 October 2004 - 01:47 PM

The company (Cyberlore) is still around, and from what they say in their forums, they really want to make the Majesty sequel, too. But they need to pay the bills, so they're working on other games first.

I remember hearing about those sound problems before; sorry, I don't recall a solution.

(I wonder how the PC version plays in VPC?)
I left my heart in Port Montyhaul.