Jump to content


WC3 crashes to desktop on quitting


  • Please log in to reply
3 replies to this topic

#1 OverLoad

OverLoad

    Heroic

  • Members
  • PipPipPipPip
  • 270 posts
  • Location:The other side of the world

Posted 20 September 2004 - 11:26 PM

I've just reinstalled WC3 and TFT on my G5, after completing a clean install and update to 10.3.4 (plus subsequent security updates). After installing the games I connected to Battle.net and got them updated to version 1.16.

Since I started playing Reign of Chaos a couple I've seen the application crash twice when I quit, usually after selecting "End mission" to stop a mission in progress. This doesn't happen every time, but I'm not sure what triggers it.

It never happened before, when I was playing an earlier version of the games (maybe 1.14?) on OS 10.3.2 or 10.3.3. Has anyone seen anything like this? Any suggestions how I can prevent the crashes?

Thanks in advance for any and all help!

#2 Malus121

Malus121

    Heroic

  • Members
  • PipPipPipPip
  • 284 posts
  • Location:Tokyo Japan

Posted 20 September 2004 - 11:58 PM

Well WC3 becamse much more stable for me when i downgraded my G5 from 10.3.5 to 10.3.3(hell my whole system is more stable now  :roll: ).
27" iMac, 2.8Ghz Quad Core i5, 8GB of ram, 1TB HDD, AMD Radeon HD 6770M w/ 512 Vram
13" Macbook Air, 1.86Ghz Core 2 Duo, 4GB of Ram, 128GB SSD, Nvidia Geforce 320M

Playstation Vita (JP 3G Model), 8GB Memory Card, Uncharted Golden Abyss, Gravity Daze, Tales of Innocence R
Playstation 3 (Lots of games..)
27" iMac..... Awesome
Playstation Vita = Amazing

#3 OverLoad

OverLoad

    Heroic

  • Members
  • PipPipPipPip
  • 270 posts
  • Location:The other side of the world

Posted 21 September 2004 - 12:23 AM

I upgraded to 10.3.4 in anticipation of getting WoW someday. Which Blizzard has already screwed up by jumping the minimum req to 10.3.5. Sigh. Ah well. If I have further trouble, maybe I'll downgrade as well.

I have come across something that may offer a clue as to why I'm seeing this problem. This morning I launched the WC3 Demo and deleted my profile in the title screen. (I figured I'd try playing the demo again fresh somewhere down the road.)

Just now, however, I opened up Reign of Chaos and tried to continue the human campaign...and the blinkin' game asked me whether I really wanted to skip the intro campaign, which "contains story elements."

It seems that when I asked the Demo program to delete my profile, it erased any progress I made in the Reign of Chaos campaign! Except that somehow Reign of Chaos still knew that I had unlocked the human campaign.

Has anyone else had a problem with WC3 and the WC3 demo both installed on their hard disk? I have both programs installed in their own folders within my Applications folder. They each have their own "Saves" folder; I don't see why one program should do anything to the profiles from the other. But on the other hand, the ATI Displays control panel seems to think that WC3 and the Demo are the same application...

#4 OverLoad

OverLoad

    Heroic

  • Members
  • PipPipPipPip
  • 270 posts
  • Location:The other side of the world

Posted 21 September 2004 - 03:11 AM

Quote

It seems that when I asked the Demo program to delete my profile, it erased any progress I made in the Reign of Chaos campaign! Except that somehow Reign of Chaos still knew that I had unlocked the human campaign.
Okay, upon reinstalling WC3 (in the hopes that would get rid of the crashing) I discovered that the human campaign is unlocked from the beginning. I guess I'd forgotten about that.

Still doesn't explain why the demo should erase my profile from the wrong folder, though. Has anyone else had problems with both WC3 and the demo installed?