Jump to content


Old games on Mac OS Sierra 10.12


  • Please log in to reply
4 replies to this topic

#1 Homy

Homy

    Notorious

  • Members
  • PipPipPip
  • 159 posts
  • Location:Sweden

Posted 31 October 2016 - 08:36 AM

Hi!

Long time since I was here but it seems like I have to upgrade to 10.12 now. I haven't played games in ages but I have a few that I hope beeing able to finish some day. I have OS 10.7.5 and wonder if CoD Deluxe, CoD 2, Halo, Prey, Jedi Academy, Quake 4 and Half-Life 1-2 (Source, Episode 1-2) will still work in Sierra. I can't find any info here or on the web. Has anyone tested these games in 10.12?

Thanks!

#2 Thain Esh Kelch

Thain Esh Kelch

    Admin

  • Members
  • PipPipPipPipPipPipPipPip
  • 3815 posts
  • Steam ID:thaineshkelch
  • Location:Denmark

Posted 31 October 2016 - 08:41 AM

You could make a 40GB partion on your Mac, and run Lion on that partion, with Sierra on the regular/full partion. Then you'll be able to play most stuff for sure in one or the other.
"They're everywhere!" -And now, time for some Legend of Zelda.

iMac 2011, quad 3,4Ghz i7, 1TB Samsung EVO 840, 8GB RAM, 2GB Radeon 6970m. + 2016 Macbook m3 + iPad 2 64GB + iPhone 4S 64GB + Girlfriend + Daughter

#3 Homy

Homy

    Notorious

  • Members
  • PipPipPip
  • 159 posts
  • Location:Sweden

Posted 31 October 2016 - 08:47 AM

View PostThain Esh Kelch, on 31 October 2016 - 08:41 AM, said:

You could make a 40GB partion on your Mac, and run Lion on that partion, with Sierra on the regular/full partion. Then you'll be able to play most stuff for sure in one or the other.
Rather not but true! It's a solution if they don't work in Sierra. :)

#4 Cougar

Cougar

    Legendary

  • Members
  • PipPipPipPipPip
  • 1371 posts
  • Steam Name:FuzzyPuffin

Posted 31 October 2016 - 12:38 PM

I think most of those should work. Jedi Academy works but you might need the MAS or Steam version, not the original. Just tried Prey, (also from MAS) it seems fine. HL 2 will definitely work. I'd contact Aspyr for their titles, they could tell you. They list CoD 1 as supporting Yosemite and CoD 2 supporting El Cap but their support pages might be out of date.

#5 Homy

Homy

    Notorious

  • Members
  • PipPipPip
  • 159 posts
  • Location:Sweden

Posted 31 October 2016 - 12:42 PM

View PostCougar, on 31 October 2016 - 12:38 PM, said:

I think most of those should work. Jedi Academy works but you might need the MAS or Steam version, not the original. Just tried Prey, (also from MAS) it seems fine. HL 2 will definitely work. I'd contact Aspyr for their titles, they could tell you. They list CoD 1 as supporting Yosemite and CoD 2 supporting El Cap but their support pages might be out of date.
Great! Thanks!