Jump to content


Member Since 10 Sep 2001
Offline Last Active Yesterday, 11:38 AM

Topics I've Started

Reinstalling OS in single user mode

27 February 2018 - 01:14 PM

Let me explain. No that would take too long. Let me sum up.

Late 2013 iMac, Fusion drive, suddenly froze up last week. Couldn't force quit anything and had to force it to power down. On restart, I get the Apple logo and progress bar and it hangs.

The weird thing is that it still works as a WiFi hotspot, though. Apparently it gets far enough into the reboot process to do that, just not get me to the UI.  Ok, do some research and start using the keyboard options on start up.  Oddly, command-R doesn't work. Nor does holding down shift to get to Safe Mode. The Apple logo and progress bar appear and it hangs. Usually around 50% or even 80% (extra frustrating as I cajole it to just keeeep gooooing).  More research and I start to find some things that *do* work.

1. I discover I can get into single user mode. I run /sbin/fsck -fy and it tells me the volume "macintosh HD" is fine. Ok. "reboot". Apple + progress bar and hangs (for brevity, A+pb&H).

2. I discover I can hold "option" and get the choose your startup disk screen. I pick "Macintosh HD" (which is the only startup drive I've ever used) and A+pb&H.  I reboot, hold option and then select the external drive that I use for Time Machine backups, thinking that maybe the iMac has somehow decided that's where all the startup programs are found. A+pb&H. (I have since disconnected that external drive when the iMac was powered down, in hopes that I can use it to restore once I get to the UI and that I don't somehow corrupt it while forcing shutdowns and rebooting a couple dozen times.)

3. I discover I can get into Diagnostics (hold D on startup). Run hardware diagnostic extended test as recommended. 30 minutes later it tells me the hardware seems fine. Ok. Reboot. A+pb&H.

4 I discover I can do the command-option-R and get into Internet Recovery (I'm really excited here b/c I'm thinking, if only I could reinstall Mac OS X I can get to the UI without losing much if anything.) A miniature globe shows up, plus a progress bar. 3 minutes later that finishes loading aaaand A+pb&H. WTF? Ok, now I shut down and try regular command + R and get .... A+pb&H.

So, I have no idea what to do next. I'd love to reinstall the OS, and I'm thinking maybe there's a way to do that in single user mode, but my knowledge of UNIX is .... zero? I only knew how to do the fsck thing after looking online.  So far my googling has yet to turn up instructions on how to reinstall my OS from single user mode. Maybe it can't be done. I've seen instructions on how to trick your Mac into thinking you're booting it up for the first time, basically creating a new user account I guess, but that seems kind of fiddly.  

Anyway, that's where I'm stuck. I think I've exhausted everything short of Apple Support, and I'm happy to call them in. Since it seems like this is just some sort of borked-up boot process, though, rather than a HD or other problem, I'd like to see if I can resolve it without hauling my iMac down to the Apple Store.  \

SO, tl; dr question: Anyone know if/how I can reinstall MacOSX in single user mode? Or, if you were brave enough to read through my list, is there anything you can see that I haven't already tried that might help?  

Help me, InsideMacGames Kenobis. You're my only hope (short of Apple Support/Store, that is.)